// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\s!?.\/.*#|]+$").unwrap();
let string = "une-ecole_123-soleil
une-école_123-soleil
une-%C3%A9cole-123_soleil";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}