#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(["'`])(?:(?=(\\?))\2.)*?\1"
Local $sString = "ggg, "hhh" " & @CRLF & _
"ggg" & @CRLF & _
""hhh" & @CRLF & _
"hhhh"" & @CRLF & _
"..." & @CRLF & _
""hh\"x\"jj"" & @CRLF & _
"..." & @CRLF & _
""%d=\"hi" & @CRLF & _
"hi\"oh"" & @CRLF & _
"" & @CRLF & _
"`gg"g" " & @CRLF & _
"\" ` " & @CRLF & _
"" & @CRLF & _
"`Hello "My" & @CRLF & _
"friend"" & @CRLF & _
"`" & @CRLF & _
"" & @CRLF & _
"'bbb'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")