using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([""'`])(?:(?=(\\?))\2.)*?\1";
string input = @"ggg, ""hhh""
ggg
""hhh
hhhh""
...
""hh\""x\""jj""
...
""%d=\""hi
hi\""oh""
`gg""g""
\"" `
`Hello ""My
friend""
`
'bbb'";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}