import re
regex = re.compile(r"([\"'`])(?:(?=(\\?))\2.)*?\1", flags=re.MULTILINE | re.DOTALL)
test_str = ("ggg, \"hhh\" \n"
"ggg\n"
"\"hhh\n"
"hhhh\"\n"
"...\n"
"\"hh\\\"x\\\"jj\"\n"
"...\n"
"\"%d=\\\"hi\n"
"hi\\\"oh\"\n\n"
"`gg\"g\" \n"
"\\\" ` \n\n"
"`Hello \"My\n"
"friend\"\n"
"`\n\n"
"'bbb'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")