#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z]{3}(?=\.)"
Local $sString = "/path/to/QAQC/Conclusions_Pakistan_2019-09-13_PAK.pdf" & @CRLF & _
"/path/to/QAQC/Conclusions_SouthAfrica_2019-09-13_ZAF.pdf" & @CRLF & _
"/path/to/QAQC/Conclusions_TheBahamas_2019-09-13_BHS.pdf" & @CRLF & _
"/path/to/QAQC/Conclusions_Venezuela_2019-09-13_VEN.pdf" & @CRLF & _
"/path/to/QAQC/Conclusions_Pakistan_2019-09-13_YEM.pdf" & @CRLF & _
"/path/to/QAQC/Conclusions_Iraq_2019-09-13_IRQ.pdf" & @CRLF & _
"/path/to/QAQC/Conclusions_Afghanistan_2019-09-13_AFG.pdf" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")