import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{3}(?=\\.)";
final String string = "/path/to/QAQC/Conclusions_Pakistan_2019-09-13_PAK.pdf\n"
+ "/path/to/QAQC/Conclusions_SouthAfrica_2019-09-13_ZAF.pdf\n"
+ "/path/to/QAQC/Conclusions_TheBahamas_2019-09-13_BHS.pdf\n"
+ "/path/to/QAQC/Conclusions_Venezuela_2019-09-13_VEN.pdf\n"
+ "/path/to/QAQC/Conclusions_Pakistan_2019-09-13_YEM.pdf\n"
+ "/path/to/QAQC/Conclusions_Iraq_2019-09-13_IRQ.pdf\n"
+ "/path/to/QAQC/Conclusions_Afghanistan_2019-09-13_AFG.pdf\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}