using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{3}(?=\.)";
string input = @"/path/to/QAQC/Conclusions_Pakistan_2019-09-13_PAK.pdf
/path/to/QAQC/Conclusions_SouthAfrica_2019-09-13_ZAF.pdf
/path/to/QAQC/Conclusions_TheBahamas_2019-09-13_BHS.pdf
/path/to/QAQC/Conclusions_Venezuela_2019-09-13_VEN.pdf
/path/to/QAQC/Conclusions_Pakistan_2019-09-13_YEM.pdf
/path/to/QAQC/Conclusions_Iraq_2019-09-13_IRQ.pdf
/path/to/QAQC/Conclusions_Afghanistan_2019-09-13_AFG.pdf
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}