import re
regex = re.compile(r"[A-Z]{3}(?=\.)")
test_str = ("/path/to/QAQC/Conclusions_Pakistan_2019-09-13_PAK.pdf\n"
"/path/to/QAQC/Conclusions_SouthAfrica_2019-09-13_ZAF.pdf\n"
"/path/to/QAQC/Conclusions_TheBahamas_2019-09-13_BHS.pdf\n"
"/path/to/QAQC/Conclusions_Venezuela_2019-09-13_VEN.pdf\n"
"/path/to/QAQC/Conclusions_Pakistan_2019-09-13_YEM.pdf\n"
"/path/to/QAQC/Conclusions_Iraq_2019-09-13_IRQ.pdf\n"
"/path/to/QAQC/Conclusions_Afghanistan_2019-09-13_AFG.pdf\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")