#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+62|08)([0-9]+)(\s[0-9]{4})+"
Local $sString = "+62812 2712 2819" & @CRLF & _
"+1812 2712 2819" & @CRLF & _
"1812 2712 2819" & @CRLF & _
"0823 2371 2318" & @CRLF & _
"+1812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")