use strict;
my $str = '+62812 2712 2819
+1812 2712 2819
1812 2712 2819
0823 2371 2318
+1812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819
';
my $regex = qr/(\+62|08)([0-9]+)(\s[0-9]{4})+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}