using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+62|08)([0-9]+)(\s[0-9]{4})+";
string input = @"+62812 2712 2819
+1812 2712 2819
1812 2712 2819
0823 2371 2318
+1812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}