package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\+62|08)([0-9]+)(\s[0-9]{4})+`)
var str = `+62812 2712 2819
+1812 2712 2819
1812 2712 2819
0823 2371 2318
+1812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}