$re = '/(\+62|08)([0-9]+)(\s[0-9]{4})+/m';
$str = '+62812 2712 2819
+1812 2712 2819
1812 2712 2819
0823 2371 2318
+1812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish0823 2371 2318any thing else you wish+62812 2712 2819
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);