#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[\[[^,\[\]]*?)(\s*),(\s*)"
Local $sString = "a, a" & @CRLF & _
"" & @CRLF & _
"[[scsdfs , asdasda]]" & @CRLF & _
"" & @CRLF & _
"[[vwdfwffwq]], [[vbsdfgv , gewgfwfgw,gewgw]]"
Local $sSubst = "\1]], [["
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)