$re = '/(\[\[[^,\[\]]*?)(\s*),(\s*)/m';
$str = 'a, a
[[scsdfs , asdasda]]
[[vwdfwffwq]], [[vbsdfgv , gewgfwfgw,gewgw]]';
$subst = "\1]], [[";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;