import Foundation
let pattern = #"(\[\[[^,\[\]]*?)(\s*),(\s*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a, a
[[scsdfs , asdasda]]
[[vwdfwffwq]], [[vbsdfgv , gewgfwfgw,gewgw]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1]], [["#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)