package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[\[[^,\[\]]*?)(\s*),(\s*)`)
var str = `a, a
[[scsdfs , asdasda]]
[[vwdfwffwq]], [[vbsdfgv , gewgfwfgw,gewgw]]`
var substitution = "\1]], [["
fmt.Println(re.ReplaceAllString(str, substitution))
}