re = /(\[\[[^,\[\]]*?)(\s*),(\s*)/m
str = 'a, a
[[scsdfs , asdasda]]
[[vwdfwffwq]], [[vbsdfgv , gewgfwfgw,gewgw]]'
subst = '\\1]], [['
result = str.gsub(re, subst)
# Print the result of the substitution
puts result