using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\s\@])+\@(([^\s\@\.])+\.)+([^\s\.]{2,})+$";
string substitution = @"";
string input = @"test@rws.lt
res+ds@gmail.com
res-dsaf@f.com
4334-@fdf.fdsfdsfdsfs.dfsd
e@ds.lt
w.w@f.lt
w--w--we@d.lr
we@rer-rer.lt
wee@we.co.uk
mindaugas.dsd@dsfs.com
c@c.com
xn--iema-kbbc.lt@xn--iema-kbbc.lt
""Joe.\\Blow""@example.com
bc.123@example.com
reŠna@g.com
квіточка@пошта.укр
""Fred\ Bloggs""@example.com
dsad@dfs.c
ewr@rsrew@dsad.com
@gf.com
ree+er@.com
res@.lt
@.lt
res.lt
sad@
s@fdf..com
es@fdf..com
w@fdsf.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}