package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([^\s\@])+\@(([^\s\@\.])+\.)+([^\s\.]{2,})+$`)
var str = `test@rws.lt
res+ds@gmail.com
res-dsaf@f.com
4334-@fdf.fdsfdsfdsfs.dfsd
e@ds.lt
w.w@f.lt
w--w--we@d.lr
we@rer-rer.lt
wee@we.co.uk
mindaugas.dsd@dsfs.com
c@c.com
xn--iema-kbbc.lt@xn--iema-kbbc.lt
"Joe.\\Blow"@example.com
bc.123@example.com
reŠna@g.com
квіточка@пошта.укр
"Fred\ Bloggs"@example.com
dsad@dfs.c
ewr@rsrew@dsad.com
@gf.com
ree+er@.com
res@.lt
@.lt
res.lt
sad@
s@fdf..com
es@fdf..com
w@fdsf.
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}