# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\s\@])+\@(([^\s\@\.])+\.)+([^\s\.]{2,})+$"
test_str = ("test@rws.lt\n"
"res+ds@gmail.com\n"
"res-dsaf@f.com\n"
"4334-@fdf.fdsfdsfdsfs.dfsd\n"
"e@ds.lt\n"
"w.w@f.lt\n"
"w--w--we@d.lr\n"
"we@rer-rer.lt\n"
"wee@we.co.uk\n"
"mindaugas.dsd@dsfs.com\n"
"c@c.com\n"
"xn--iema-kbbc.lt@xn--iema-kbbc.lt\n"
"\"Joe.\\\\Blow\"@example.com\n"
"bc.123@example.com\n"
"reŠna@g.com\n"
"квіточка@пошта.укр\n\n\n"
"\"Fred\\ Bloggs\"@example.com\n"
"dsad@dfs.c\n"
"ewr@rsrew@dsad.com\n"
"@gf.com\n"
"ree+er@.com\n"
"res@.lt\n"
"@.lt\n"
"res.lt\n"
"sad@\n"
"s@fdf..com\n"
"es@fdf..com\n"
"w@fdsf.\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.