import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\s\\@])+\\@(([^\\s\\@\\.])+\\.)+([^\\s\\.]{2,})+$";
final String string = "test@rws.lt\n"
+ "res+ds@gmail.com\n"
+ "res-dsaf@f.com\n"
+ "4334-@fdf.fdsfdsfdsfs.dfsd\n"
+ "e@ds.lt\n"
+ "w.w@f.lt\n"
+ "w--w--we@d.lr\n"
+ "we@rer-rer.lt\n"
+ "wee@we.co.uk\n"
+ "mindaugas.dsd@dsfs.com\n"
+ "c@c.com\n"
+ "xn--iema-kbbc.lt@xn--iema-kbbc.lt\n"
+ "\"Joe.\\\\Blow\"@example.com\n"
+ "bc.123@example.com\n"
+ "reŠna@g.com\n"
+ "квіточка@пошта.укр\n\n\n"
+ "\"Fred\\ Bloggs\"@example.com\n"
+ "dsad@dfs.c\n"
+ "ewr@rsrew@dsad.com\n"
+ "@gf.com\n"
+ "ree+er@.com\n"
+ "res@.lt\n"
+ "@.lt\n"
+ "res.lt\n"
+ "sad@\n"
+ "s@fdf..com\n"
+ "es@fdf..com\n"
+ "w@fdsf.\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}