// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^([^\s\@])+\@(([^\s\@\.])+\.)+([^\s\.]{2,})+$").unwrap();
let string = "test@rws.lt
res+ds@gmail.com
res-dsaf@f.com
4334-@fdf.fdsfdsfdsfs.dfsd
e@ds.lt
w.w@f.lt
w--w--we@d.lr
we@rer-rer.lt
wee@we.co.uk
mindaugas.dsd@dsfs.com
c@c.com
xn--iema-kbbc.lt@xn--iema-kbbc.lt
\"Joe.\\\\Blow\"@example.com
bc.123@example.com
reŠna@g.com
квіточка@пошта.укр
\"Fred\\ Bloggs\"@example.com
dsad@dfs.c
ewr@rsrew@dsad.com
@gf.com
ree+er@.com
res@.lt
@.lt
res.lt
sad@
s@fdf..com
es@fdf..com
w@fdsf.
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}