package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"([^"]*\bsearchword\b[^"]*)"|'([^']*\bsearchword\b[^']*)'|"[^"]*"|'[^']*'`)
var str = `This "searchword1". searchword. "searchword"
This 'searchword2'. searchword. "searchword"
This 'searchword 2'. searchword. "Hello, searchword!"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}