$re = '/"([^"]*\bsearchword\b[^"]*)"|\'([^\']*\bsearchword\b[^\']*)\'|"[^"]*"|\'[^\']*\'/m';
$str = 'This "searchword1". searchword. "searchword"
This \'searchword2\'. searchword. "searchword"
This \'searchword 2\'. searchword. "Hello, searchword!"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);