const regex = /"([^"]*\bsearchword\b[^"]*)"|'([^']*\bsearchword\b[^']*)'|"[^"]*"|'[^']*'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"]*\\bsearchword\\b[^"]*)"|\'([^\']*\\bsearchword\\b[^\']*)\'|"[^"]*"|\'[^\']*\'', 'gm')
const str = `This "searchword1". searchword. "searchword"
This 'searchword2'. searchword. "searchword"
This 'searchword 2'. searchword. "Hello, searchword!"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}