using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# Section header
^ [ \t]* \[ [ \t]* \w+ [ \t]* \] [ \t]* (?:\r?\n)+
# Section items
(?:
^
(?:
# key = value
[ \t]* [^\r\n=]+ [ \t]* = [ \t]* [^\r\n]* [ \t]*
|
# comment line
[ \t]* \# [^\r\n]*
|
# blank
[ \t]*
)
(?: \r?\n | $ )
) *";
string input = @"[ keybinds ]
# comment
bksp = reload
# comment
space = jump # not comment
[settings ]
resolution = 640 x 480
max_framerate = 24
[character]
# This is a comment. This section is empty.
[weapons]
[server]
login = hexology
password = my password # is not a comment";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}