import re
regex = re.compile(r"""
# Section header
^ [ \t]* \[ [ \t]* \w+ [ \t]* \] [ \t]* (?:\r?\n)+
# Section items
(?:
^
(?:
# key = value
[ \t]* [^\r\n=]+ [ \t]* = [ \t]* [^\r\n]* [ \t]*
|
# comment line
[ \t]* \# [^\r\n]*
|
# blank
[ \t]*
)
(?: \r?\n | $ )
) *
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("[ keybinds ]\n"
"# comment\n"
"bksp = reload\n"
"# comment\n"
"space = jump # not comment\n\n"
" [settings ]\n\n"
"resolution = 640 x 480\n"
"max_framerate = 24\n\n"
"[character]\n"
"# This is a comment. This section is empty.\n\n"
"[weapons]\n\n"
"[server]\n"
"login = hexology\n"
"password = my password # is not a comment")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")