// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)# Section header
^ [ \t]* \[ [ \t]* \w+ [ \t]* \] [ \t]* (?:\r?\n)+
# Section items
(?:
^
(?:
# key = value
[ \t]* [^\r\n=]+ [ \t]* = [ \t]* [^\r\n]* [ \t]*
|
# comment line
[ \t]* \# [^\r\n]*
|
# blank
[ \t]*
)
(?: \r?\n | $ )
) *").unwrap();
let string = "[ keybinds ]
# comment
bksp = reload
# comment
space = jump # not comment
[settings ]
resolution = 640 x 480
max_framerate = 24
[character]
# This is a comment. This section is empty.
[weapons]
[server]
login = hexology
password = my password # is not a comment";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}