const regex = new RegExp('# Section header
^ [ \\t]* \\[ [ \\t]* \\w+ [ \\t]* \\] [ \\t]* (?:\\r?\\n)+
# Section items
(?:
^
(?:
# key = value
[ \\t]* [^\\r\\n=]+ [ \\t]* = [ \\t]* [^\\r\\n]* [ \\t]*
|
# comment line
[ \\t]* \\# [^\\r\\n]*
|
# blank
[ \\t]*
)
(?: \\r?\\n | $ )
) *', 'mig')
const str = `[ keybinds ]
# comment
bksp = reload
# comment
space = jump # not comment
[settings ]
resolution = 640 x 480
max_framerate = 24
[character]
# This is a comment. This section is empty.
[weapons]
[server]
login = hexology
password = my password # is not a comment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}