use strict;
my $str = '[ keybinds ]
# comment
bksp = reload
# comment
space = jump # not comment
[settings ]
resolution = 640 x 480
max_framerate = 24
[character]
# This is a comment. This section is empty.
[weapons]
[server]
login = hexology
password = my password # is not a comment';
my $regex = qr/# Section header
^ [ \t]* \[ [ \t]* \w+ [ \t]* \] [ \t]* (?:\r?\n)+
# Section items
(?:
^
(?:
# key = value
[ \t]* [^\r\n=]+ [ \t]* = [ \t]* [^\r\n]* [ \t]*
|
# comment line
[ \t]* \# [^\r\n]*
|
# blank
[ \t]*
)
(?: \r?\n | $ )
) */mixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}