package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<!([a-z]{0,25})\|([^|>]*)\|([^|<>]*)(?:\|([^|<>]*))?>`)
var str = `<!user|123|Kirill|{"color":"rgb(255, 184, 75)"}> published <!content|456|A cool content>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}