import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!([a-z]{0,25})\\|([^|>]*)\\|([^|<>]*)(?:\\|([^|<>]*))?>";
final String string = "<!user|123|Kirill|{\"color\":\"rgb(255, 184, 75)\"}> published <!content|456|A cool content>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}