re = /<!([a-z]{0,25})\|([^|>]*)\|([^|<>]*)(?:\|([^|<>]*))?>/m
str = '<!user|123|Kirill|{"color":"rgb(255, 184, 75)"}> published <!content|456|A cool content>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end