const regex = /<!([a-z]{0,25})\|([^|>]*)\|([^|<>]*)(?:\|([^|<>]*))?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!([a-z]{0,25})\\|([^|>]*)\\|([^|<>]*)(?:\\|([^|<>]*))?>', 'gm')
const str = `<!user|123|Kirill|{"color":"rgb(255, 184, 75)"}> published <!content|456|A cool content>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}