$re = '/<!([a-z]{0,25})\|([^|>]*)\|([^|<>]*)(?:\|([^|<>]*))?>/m';
$str = '<!user|123|Kirill|{"color":"rgb(255, 184, 75)"}> published <!content|456|A cool content>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);