import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bif\\s*([^:]+):\\s+([^:]+)\\s+(?:else:\\s+([^:]+)\\s+)?endif\\b";
final String string = "Text if(stat(fire) ): x else: w endif\n"
+ " if o: s endif; \n"
+ " if is_night(): die(); horribly(); else: live() endif\n\n"
+ "attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); else: heal(-1) endif; draw(1)\n\n"
+ "if multiline():\n"
+ " abc\n"
+ "else:\n"
+ " def\n"
+ "endif";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}