const regex = /\bif\s*([^:]+):\s+([^:]+)\s+(?:else:\s+([^:]+)\s+)?endif\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bif\\s*([^:]+):\\s+([^:]+)\\s+(?:else:\\s+([^:]+)\\s+)?endif\\b', 'gm')
const str = `Text if(stat(fire) ): x else: w endif
if o: s endif;
if is_night(): die(); horribly(); else: live() endif
attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); else: heal(-1) endif; draw(1)
if multiline():
abc
else:
def
endif`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}