re = /\bif\s*([^:]+):\s+([^:]+)\s+(?:else:\s+([^:]+)\s+)?endif\b/m
str = 'Text if(stat(fire) ): x else: w endif
if o: s endif;
if is_night(): die(); horribly(); else: live() endif
attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); else: heal(-1) endif; draw(1)
if multiline():
abc
else:
def
endif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end