// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bif\s*([^:]+):\s+([^:]+)\s+(?:else:\s+([^:]+)\s+)?endif\b").unwrap();
let string = "Text if(stat(fire) ): x else: w endif
if o: s endif;
if is_night(): die(); horribly(); else: live() endif
attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); else: heal(-1) endif; draw(1)
if multiline():
abc
else:
def
endif";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}