import re
regex = re.compile(r"\bif\s*([^:]+):\s+([^:]+)\s+(?:else:\s+([^:]+)\s+)?endif\b", flags=re.MULTILINE)
test_str = ("Text if(stat(fire) ): x else: w endif\n"
" if o: s endif; \n"
" if is_night(): die(); horribly(); else: live() endif\n\n"
"attack(5); if attack_was_lethal(): heal(1); gain(block, get_stat(strength)); else: heal(-1) endif; draw(1)\n\n"
"if multiline():\n"
" abc\n"
"else:\n"
" def\n"
"endif")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")