import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "logfiles(.*)\\.zoom\\.us";
final String string = "logfiles-va-3.zoom.us\n"
+ "logfiles-va-4.zoom.us\n"
+ "logfiles-va-5.zoom.us\n"
+ "logfiles-va-6.zoom.us\n"
+ "logfiles-va-za1.zoom.us\n"
+ "logfiles-va-zd1.zoom.us\n"
+ "logfiles-va.zoom.us\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}