// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)logfiles(.*)\.zoom\.us").unwrap();
let string = "logfiles-va-3.zoom.us
logfiles-va-4.zoom.us
logfiles-va-5.zoom.us
logfiles-va-6.zoom.us
logfiles-va-za1.zoom.us
logfiles-va-zd1.zoom.us
logfiles-va.zoom.us
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}