$re = '/logfiles(.*)\.zoom\.us/m';
$str = 'logfiles-va-3.zoom.us
logfiles-va-4.zoom.us
logfiles-va-5.zoom.us
logfiles-va-6.zoom.us
logfiles-va-za1.zoom.us
logfiles-va-zd1.zoom.us
logfiles-va.zoom.us
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);