import re
regex = re.compile(r"logfiles(.*)\.zoom\.us", flags=re.MULTILINE)
test_str = ("logfiles-va-3.zoom.us\n"
"logfiles-va-4.zoom.us\n"
"logfiles-va-5.zoom.us\n"
"logfiles-va-6.zoom.us\n"
"logfiles-va-za1.zoom.us\n"
"logfiles-va-zd1.zoom.us\n"
"logfiles-va.zoom.us\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")