const regex = /logfiles(.*)\.zoom\.us/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('logfiles(.*)\\.zoom\\.us', 'gm')
const str = `logfiles-va-3.zoom.us
logfiles-va-4.zoom.us
logfiles-va-5.zoom.us
logfiles-va-6.zoom.us
logfiles-va-za1.zoom.us
logfiles-va-zd1.zoom.us
logfiles-va.zoom.us
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}