#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$_(GET|POST|REQUEST)\[[^\]]*\]"
Local $sString = "<?php " & @CRLF & _
"// before" & @CRLF & _
"$firstname = $_GET['firstname'];" & @CRLF & _
"$lastname = $_POST['lastname'];" & @CRLF & _
"$age = $_REQUEST['age'];" & @CRLF & _
"?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")