$re = '/\$_(GET|POST|REQUEST)\[[^\]]*\]/';
$str = '<?php
// before
$firstname = $_GET[\'firstname\'];
$lastname = $_POST[\'lastname\'];
$age = $_REQUEST[\'age\'];
?>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);