import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$_(GET|POST|REQUEST)\\[[^\\]]*\\]";
final String string = "<?php \n"
+ "// before\n"
+ "$firstname = $_GET['firstname'];\n"
+ "$lastname = $_POST['lastname'];\n"
+ "$age = $_REQUEST['age'];\n"
+ "?>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}