re = /\$_(GET|POST|REQUEST)\[[^\]]*\]/
str = '<?php
// before
$firstname = $_GET[\'firstname\'];
$lastname = $_POST[\'lastname\'];
$age = $_REQUEST[\'age\'];
?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end